Kaspersky Automated Security Awareness Platform
 
 

User account issues after synchronizing Kaspersky Automated Security Awareness Platform with the local Active Directory service

Latest update: July 26, 2024 ID: 16088
 
 
 
 

Issue

After synchronizing with the local Active Directory service, one of the following problems may occur in Kaspersky Automated Security Awareness Platform (KASAP):

  • User accounts are deleted.
  • Course completion progress and certificates are missing from user accounts.

Cause

Before synchronization in Active Directory, UPNs had been changed, e.g. the domain had been changed in the UPN suffix. KASAP detects users by this parameter, so during synchronization it removes the users whose names it cannot find and adds new users with new names.

If the Delete check box is selected in the Permitted actions with users, accounts with old UPNs will be deleted. If the Archive check box is selected, they will be archived.

Solution

Check the user archive in KASAP. To do this, click Show archived users in the Users section.

  • If the user accounts were archived:
    1. Temporarily remove the synchronization script to be able to manage users manually.
    2. Restore the user accounts from the archive manually using these instructions.
    3. Add the synchronization script again.
  • If there are no user accounts in the archive, it's not possible to restore them. Add the user accounts again using this guide.
    To prevent users from retaking courses again, enable the Early tests option: the users will only have to retake the test to receive a certificate. You can also configure the Test threshold level and set it to 0 so that all users who pass tests with any number of correct answers will receive certificates.

What to do if the issue persists

If the issue persists, submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount.

 
 
 
 
 
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