Errors during backup in Kaspersky Security Center
Show applications and versions that this article concerns
- Kaspersky Security Center 14.2 (version 14.2.0.26967)
- Kaspersky Security Center 14 (version 14.0.0.10902)
- Kaspersky Security Center 13.2 (version 13.2.0.1511)
When backing up data in Kaspersky Security Center, errors may occur. The most common causes are:
- Operating system or hardware resources malfunction;
- Lack of required permissions to perform backups;
- klbackup tool malfunction;
- Databases are corrupted or configuration files do not match the state of the databases.
You can find the details about these errors and solutions below, but first check that the following conditions are met:
- Your device meets Kaspersky Security Center hardware and system requirements.
- SQL server platform is updated to the latest version.
- The latest SQL server patch is installed.
Error when creating a backup copy
When creating a backup copy, the error message “Invalid folder path. Error 1181/0x52e has occurred because Administration Server has no write permission in...” appears.
Solution
- Check whether the user accounts that run Administration Server and SQL Server services have permissions to access and write data to a shared folder.
- Check that the shared folder exists and can be accessed from the Administration Server and SQL Server.
- Configure the access permissions for the folder to which the backup will be performed.
The klbackup tool or backup task error
The klbackup tool or backup task may display the following error in the klbackup.log file: «Backing up db ... FAILED - check whether SQL Server has enough permissions to access backup path ... Cannot open backup device ... Operating system error 3 (error not found).».
Solution
- Use an UNC path to the backup folder if the SQL Server and Administration Server are located on different computers. This is necessary so that the klbackup tool and SQL Server have access to the backup folder at the same time. For details about UNC paths, see the Microsoft support site.
- Configure the access permissions for the folder to which the backup will be performed. The SQL Server can only create or restore backups in a folder that it can access directly (this requirement is irrelevant for MySQL). The folder must be shared with read and write permissions (ACLs must be configured for sharing and NTFS).
If the issue still persists, use the instructions below.
The backup task ends with an error
The backup task in the klbackup.log file may end with the following error: “Backing up db ... FAILED - check whether SQL Server has enough permissions to access backup path ... Cannot open backup device ... Operating system error 3 (error not found).”.
Solution
- Exit the klbackup tool if it is open.
- Open Task Manager and terminate the klbackup.exe processes, if any.
- Enable the level 4 tracing of the Administration Server and start the backup task (manually or according to its schedule).
- Wait until the error appears.
- Disable the Administration Server tracing.
- Export the task history with the error to a text file.
- Collect the following files on the computer with the Administration Server installed: $klserver-1093.log, $klserver-1093.log.bak, $klbackup-1093.log, klbackup.log and an event log.
- Submit a request to Technical Support through Kaspersky CompanyAccount. Attach the collected files and the exported task history to your request.
The klbackup tool fails with an error
The klbackup tool may fail with the following error: “Backing up db ... FAILED - check whether SQL Server has enough permissions to access backup path ... Cannot open backup device ... Operating system error 3 (error not found).”.
Solution
- Exit the klbackup tool if it is open.
- Open Task Manager and terminate the klbackup.exe processes, if any.
- Enable the level 4 tracing of the Administration Server.
- Start the tool and wait until the error occurs.
- Disable the Administration Server tracing.
- Save the error description to a text file.
- Collect the following files on the computer with the Administration Server installed: $klserver-1093.log, $klserver-1093.log.bak, $klbackup-1093.log and an event log.
- Submit a request to Technical Support through Kaspersky CompanyAccount. Attach the collected files and the saved error description to your request.
Generic database error during a backup task
The backup task may end with the following error: “Generic DB error: “8985 'Could not locate file 'DATABASE_LOG' for database 'KSCSDB' in sys.database_files. The file either does not exist, or was dropped.{42000};'LastStatement='DBCC SHRINKFILE (DATABASE_LOG);’’.
Cause
The error occurs because the physical and logical database file names don’t match. This may happen if you created the Kaspersky Security Center server database yourself and changed the logical file name.
Solution
Change the logical database file name so it matches the physical name.
The “Database is corrupted” error during a backup task
The backup task may end with the following error: “Database is corrupted. At least one repository C:\ProgramData\Application Data\KasperskyLab\adminkit\1093\gsyn\klsdata.dat has been corrupted and will not be recovered. Hardware fixing and application reinstallation are required.”.
Cause
The error may occur because of the operating system malfunction or an unexpected reboot of the system with disk caching enabled (for example, due to a power loss). This leads to the corruption of the Kaspersky Security Center repositories.Solution
- Uninstall Kaspersky Security Center.
- Reinstall Kaspersky Security Center.
- Restore the latest backup copy using the klbackup tool.