Le service kladminserver ne démarre pas après la mise à niveau de Kaspersky Security Center

Dernière mise à jour : 20 juin 2022 Article ID : 15814
 
 
 
 
Les informations s'appliquent à Kaspersky Security Center 13.2 (version 13.2.0.1511).
 
 
 
 

Problème

Après la mise à niveau de Kaspersky Security Center vers la version 13.2 le service kladminserver peut ne pas démarrer et le journal des événements peut contenir le message suivant :
« Le service 'kladminserver' a été arrêté à cause d'une erreur. #1950 (102) Generic db error: "102 'Incorrect syntax near '('.{42000};' LastStatement='EXEC grp_sync_subgroups'" ».

Cause

Le problème est dû au niveau de compatibilité de la base de données incorrect spécifié dans dans Microsoft SQL Server.

Solution

Modifiez le niveau de compatibilité de la base de données dans Microsoft SQL Server Management Studio à l’aide de la commande suivante :

ALTER DATABASE <nom de la bases de données> SET COMPATIBILITY_LEVEL = <niveau de compatibilité>

Si vous utilisez Microsoft SQL Server Express Edition, téléchargez la version gratuite de Microsoft SQL Server Management Studio.

Spécifiez le niveau de compatibilité selon la version de Microsoft SQL Server utilisée :

Versions de Microsoft SQL Server Niveau de compatibilité
2014 (12.x) 120
2016 (13.x) 130
2017 (14.x) 140
2019 (15.x) 150

Vous pouvez également modifier le niveau de compatibilité de la base de données via l'interface de SQL Management Studio. Pour les instructions, consultez le site du support de Microsoft.

 
 
 
 

Que faire si le problème persiste

 
 
 
 
 
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