Error "Cannot add a reserve key if the corresponding license expired before the current license”
Show applications and versions that this article concerns
- Kaspersky Endpoint Security 12.5 for Windows (version 12.5.0.539)
- Kaspersky Endpoint Security 12.4 for Windows (version 12.4.0.467)
- Kaspersky Endpoint Security 12.3 for Windows (version 12.3.0.493)
- Kaspersky Endpoint Security 12.2 for Windows (version 12.2.0.462)
- Kaspersky Endpoint Security 12.1 for Windows (version 12.1.0.506)
- Kaspersky Endpoint Security 12 for Windows (version 12.0.0.465)
- Kaspersky Endpoint Security 11.11 for Windows (version 11.11.0.452)
- Kaspersky Endpoint Security 11.10 for Windows (version 11.10.0.399)
- Kaspersky Endpoint Security 11.9 for Windows (version 11.9.0.351)
- Kaspersky Endpoint Security 11.8 for Windows (version 11.8.0.384)
- Kaspersky Endpoint Security 11.7 for Windows (version 11.7.0.669)
Issue
Errors may occur during the activation of Kaspersky Endpoint Security for Windows.
The error "Cannot add a reserve key if the corresponding license expired before the current license” may occur when trying to install a new license.
Cause
A new license expires earlier than the current Kaspersky Endpoint Security for Windows license.
Solution
To replace the license in advance:
- Clear the Automatically distributed license key check box in the properties of the license you want to remove.
- Remove the license via the local Kaspersky Endpoint Security for Windows interface.
- Install the new license.
To remove a license centrally via the Administration Server:
- Clear the Automatically distributed license key check box in the properties of the license you want to remove.
- Remove the license using a custom installation package with a batch file and license removal commands.
- Reinstall Kaspersky Endpoint Security for Windows on the managed device.
What to do if the issue persists
Follow the instructions below and check the result after each step:
- Restart the operating system on the device with the activation problem.
- Reissue the license key file and use the new key file for licensing.
- Reinstall Kaspersky Endpoint Security for Windows on the managed device.
- Install the latest cumulative patch.
- Install the latest version of Kaspersky Endpoint Security for Windows.
- Install the latest cumulative patch for the latest Kaspersky Endpoint Security for Windows version.
You can also find answers to other questions about licensing in the Answers to frequently asked questions.
If the issue persists, collect diagnostic data and submit a request to Kaspersky Technical Support via Kaspersky CompanyAccount. Also attach the Kaspersky Endpoint Security for Windows trace files and a report from the Administration Server about the use of the license keys.