Failed to connect to Kaspersky Secure Mail Gateway server via SSH
Latest update: August 05, 2022
ID: 15904
Issue
Connection to Kaspersky Secure Mail Gateway server via SSH through added key fails.
Cause
- The license key was created incorrectly.
- The license key was modified before you added it to Kaspersky Secure Mail Gateway.
- Your loin is incorrect.
Solution
- Download the PuTTy SSH client to your device.
- Run puttygen.exe.
- In the Parameters section, select RSA type of key and click Generate.
- Copy the generated key.
- Go to Kaspersky Secure Mail Gateway and add the key without the rsa‑key‑<generation date> part. For instructions, see Online Help.
- Click Add.
- In the PuTTy key generator window, open the File tab and in the drop-down menu select Save private key.
- Open putty.exe from the PuTTy installation folder.
- Click the Session category and specify the address to connect in the Host Name (or IP address)field.
- Expand Connection → SSH and click Auth.
- In the Private key file for authentication field, open the file with the private key and click Open..
- In the window that opens, type the login: root
You will be authorized in the system without a password and will get access to the files on the server.
What to do if the solution did not help
If the issue persists, send a request to Kaspersky technical support via Kaspersky CompanyAccount. Please include a detailed description of the issue. Before sending a request, read the required information in the Knowledge Base section.