Kaspersky application blocks access to the webcam for trusted applications
Latest update: July 11, 2023
ID: 15545
This article concerns:
- Kaspersky Security Cloud
- Kaspersky Internet Security
- Kaspersky Anti-Virus
- Kaspersky Total Security
Issue
A Kaspersky application blocks access to the webcam for applications that have been included in the group of trusted and have all the permissions.
Cause
The application inherits the rules from the parent application that launched it.
For example, you have disabled access to the webcam for your browser. If you join a Zoom conference via a browser link, the webcam will not work. In this case, Zoom inherits the rules for your browser.
Solution
- Check that the application is allowed access to the webcam. See Online Help for more information.
- In the main window of a Kaspersky application, click More Tools.
- If you’re not sure how to open the application, see this article.
- Go to the Manage applications section and select Application Control.
- Click Manage applications.
- Enter the application name in the search field.
- Right-click on the application name and select Details and rules.
- Go to the Exclusions tab.
- Select the checkbox Do not inherit restrictions from the (application’s) parent process.
- Click Save.
- Click Yes in the confirmation window.
What to do if the issue persists
If the issue persists, contact Kaspersky Customer Service by choosing the topic and filling out the form.