Error adding snap-ins of Kaspersky Security 9.x for Microsoft Exchange Servers to 32-bit Windows Server 2008 R2 console

Latest update: January 13, 2023 ID: 12616
 
 
 
 
This article refers to Kaspersky Security 9.5 for Microsoft Exchange Servers Maintenance Release 5 Hotfix 1 (version 9.5.10000.64).
 
 
 
 

Issue

When adding Kaspersky Security 9.x for Microsoft Exchange Servers snap-ins to 32-bit Windows Server 2008 R2 console, you can encounter the following error, along with with the MMC collapse:

kse9_12616_01

Cause:

MMC console can use .NET Framework which is different from what is required by our snap-ins.

Solution:

To run the console, subsequently execute the following commands or add them into the command file:
  • set COMPLUS_Version=v4.0.30319
  • mmc.exe /32 — to run a blank console with subsequent snap-ins adding, or mmc.exe /32 <Path to a set of saved snap-ins> — to run with a set of snap-ins.
Executing the command for running the console via the command line

What to do if the issue persists

If the issue persists, submit a request to Kaspersky technical support via Kaspersky CompanyAccount. Before contacting the support, see the guide on creating a request in the Knowledge Base.

 
 
 
 
 
Did you find this article helpful?
What can we do better?
Thank you for your feedback! You're helping us improve.
Thank you for your feedback! You're helping us improve.