Kaspersky Anti-Virus 2017 System Requirements

 

 

Kaspersky Anti-Virus 2017

 
 
 

Kaspersky Anti-Virus 2017 System Requirements

Back to "Installation and Removal"
2017 Oct 25 ID: 12918
 
 
 
 

General requirements:

  • 920 MB of free disk space
  • CD/DVD drive (when installing from a CD)
  • Internet connection (for installation and activation, participation in Kaspersky Secure Network, as well as database and program module updates).
  • Computer mouse
  • Microsoft Internet Explorer 8.0 or later
  • Microsoft Windows Installer 3.0 or later
  • Microsoft .Net Framework 4 or later

Netbook requirements:

  • Intel Atom processor at 1.6 GHz or faster
  • Intel GMA950 video card with at least 64 MB of memory (or compatible equivalent)
  • Screen resolution of at least 1024×600.

Supported browsers:

  • Microsoft Internet Explorer 8.0 or later.
  • Microsoft Edge 20.x – 25.x and later
  • Mozilla Firefox 52.x  and later
  • Google Chrome 44.x – 52.x
  • Mozilla Firefox ESR 52.x and later

Operating systems:

  • Microsoft Windows XP Home Edition SP3 or later / Professional SP3 or later / Professional SP2 or later (64-bit)
    • Intel Pentium 1 GHz or faster (or a compatible equivalent)
    • 512 MB available RAM
  • Microsoft Windows Vista Home Basic / Home Premium / Business / Ultimate SP1 or later (32/64-bit)  
  • Microsoft Windows 7 Starter / Home Basic / Home Premium / Professional / Ultimate SP1 or later (32/64-bit)
  • Microsoft Windows 8 / Pro / Enterprise (32/64-bit)
  • Microsoft Windows 8.1 (Windows 8.1 Update) / Pro / Enterprise (32/64-bit)
  • Microsoft Windows 10 Home / Pro / Enterprise TH2 / RS1 / RS2 / RS3 (32/64-bit)  
    • Intel Pentium 1 GHz or faster (or a compatible equivalent)
    • 1 GB (32-bit) / 2 GB (64-bit) available RAM
Limitations:
  • The product cannot be installed on Windows XP if it uses the FAT32 file system.
  • To access the My Kaspersky portal, we recommend using Microsoft Internet Explorer 9.0 or later.
  • The Kaspersky Protection extension is not supported in Microsoft Edge or Microsoft Internet Explorer 10 and 11 in the new Windows user interface style.
  • The Kaspersky Protection extension does not support Firefox versions earlier than 52.x.
 
 
 
 
Was this information helpful?
Yes No
 

 
 

Have you found what you were looking for?

Please let us know how we can make this website more comfortable for you

Send feedback Send feedback

Thank you!

Thank you for submitting your feedback.
We will review your feedback shortly.