Windows Installer Service is busy
We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.
Accept and close

 

 
 

Windows Installer Service is busy

Back to "Installation errors"
2018 Dec 17 ID: 13840
 
 
 
 

Cause

The Windows Installer Service does not allow you to install multiple applications at the same time.  

Solution

  • Wait until the other application has finished installing. Try installing the Kaspersky Lab product once again. 
  • Restart the operating system and try installing the Kaspersky Lab product once again.

If this solution didn’t work, use the Process Explorer application:

  1. Download the ProcessExplorer.zip archive and unpack it.
  2. Right-click on the procexp.exe file and select Run as administrator from the shortcut menu.
  3. Press Ctrl+F on the keyboard, enter _MSIExecute in the search field and click Search. You will find the process that is using the Windows Installer Service.
  4. Kill the process and try installing the Kaspersky Lab product once again.
  5. If killing the process didn’t help, find and suspend the Windows service relevant to the process. Try installing the Kaspersky Lab product once again.

Common cases

The Windows Indexing Service is often the cause of this issue. Should this be the case, use Process Explorer to find the SearchFilterHost.exe process.

Search for the process that’s interrupting the installation of a Kaspersky Lab application

Suspend the Windows Indexing Service and try installing the Kaspersky Lab product once again.      

 
 
 
 
 

What to do if the error persists

 
 
 
 
Was this information helpful?
Yes No
Thank you
 

 
 

Have you found what you were looking for?

Please let us know how we can make this website more comfortable for you

Send feedback Send feedback

Thank you!

Thank you for submitting your feedback.
We will review your feedback shortly.

 

How can we improve this article?

We will not be able to contact you if you leave your email address or phone number. To contact technical support, please sign in to your Personal Account.

Submit Submit

Thank you for your feedback!

Your suggestions will help improve this article.

OK