Error connecting a Kaspersky application to My Kaspersky due to unsecured Internet connection

 
 

Error connecting a Kaspersky application to My Kaspersky due to unsecured Internet connection

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Latest update: July 22, 2021 ID: 13914
 
 
 
 

Issue

When connecting a Kaspersky application to My Kaspersky, you get the error saying that your connection is not secure.

Problems with connection

Cause

Possible causes:

  • Problems with the DNS service in the operating system
  • Problems with the certificates in the operating system
  • Problems with the certificates on My Kaspersky
  • Blockings by your proxy server or Internet provider

Solution

  1. Update antivirus databases.

If the application is not activated, you will need to enter the activation code manually before updating the databases. You can find the activation code in the message sent to the email address you have specified when purchasing the license or registering in My Kaspersky (for purchases made through the My Kaspersky store). 

  1. Restart the computer once the updates have been installed.
  2. Start the application and try connecting it to My Kaspersky once again.  
  3. If it did not help, try one of the following options:
    • In case of problems with the DNS service in the operating system, see this article.
    • In case of problems with the certificates in the operating system, see this article.
 
 
 
 
 

What to do if the issue persists

 
 
 
 
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