Kaspersky Security Center

Administration Server requirements

July 8, 2024

ID 255791

Minimum hardware requirements:

  • CPU with an operating frequency of 1 GHz or higher. For a 64-bit operating system, the minimum CPU frequency is 1.4 GHz.
  • RAM: 4 GB.
  • Available disk space: 10 GB. When Vulnerability and patch management is used, at least 100 GB of free disk space must be available.

For deployment in cloud environments, the requirements for Administration Server and database server are the same as the requirements for physical Administration Server (depending on how many devices you want to manage).

Software requirements:

  • Microsoft® Data Access Components (MDAC) 2.8
  • Microsoft Windows® DAC 6.0
  • Microsoft Windows Installer 4.5

The following operating systems are supported:

  • Windows Server 2008 R2 Standard with Service Pack 1 and later 64-bit
  • Windows Server 2012 Server Core 64-bit
  • Windows Server 2012 Datacenter 64-bit
  • Windows Server 2012 Essentials 64-bit
  • Windows Server 2012 Foundation 64-bit
  • Windows Server 2012 Standard 64-bit
  • Windows Server 2012 R2 Server Core 64-bit
  • Windows Server 2012 R2 Datacenter 64-bit
  • Windows Server 2012 R2 Essentials 64-bit
  • Windows Server 2012 R2 Foundation 64-bit
  • Windows Server 2012 R2 Standard 64-bit
  • Windows Server 2016 Datacenter (LTSB) 64-bit
  • Windows Server 2016 Standard (LTSB) 64-bit
  • Windows Server 2016 Server Core (Installation Option) (LTSB) 64-bit
  • Windows Server 2019 Standard 64-bit
  • Windows Server 2019 Datacenter 64-bit
  • Windows Server 2019 Core 64-bit
  • Windows Server 2022 Standard 64-bit
  • Windows Server 2022 Datacenter 64-bit
  • Windows Server 2022 Core 64-bit
  • Windows Storage Server 2012 64-bit
  • Windows Storage Server 2012 R2 64-bit
  • Windows Storage Server 2016 64-bit
  • Windows Storage Server 2019 64-bit

The following virtualization platforms are supported:

  • VMware vSphere 6.7
  • VMware vSphere 7.0
  • VMware Workstation 16 Pro
  • Microsoft Hyper-V Server 2012 64-bit
  • Microsoft Hyper-V Server 2012 R2 64-bit
  • Microsoft Hyper-V Server 2016 64-bit
  • Microsoft Hyper-V Server 2019 64-bit
  • Microsoft Hyper-V Server 2022 64-bit
  • Citrix XenServer 7.1 LTSR
  • Citrix XenServer 8.x
  • Parallels Desktop 17
  • Oracle VM VirtualBox 6.x

The following database servers are supported (can be installed on a different device):

  • Microsoft SQL Server 2012 Express 64-bit with limitations
  • Microsoft SQL Server 2014 Express 64-bit with limitations
  • Microsoft SQL Server 2016 Express 64-bit with limitations
  • Microsoft SQL Server 2017 Express 64-bit with limitations
  • Microsoft SQL Server 2019 Express 64-bit with limitations
  • Microsoft SQL Server 2014 (all editions) 64-bit
  • Microsoft SQL Server 2016 (all editions) 64-bit
  • Microsoft SQL Server 2017 (all editions) on Windows 64-bit
  • Microsoft SQL Server 2017 (all editions) on Linux 64-bit
  • Microsoft SQL Server 2019 (all editions) on Windows 64-bit (requires additional actions)
  • Microsoft SQL Server 2019 (all editions) on Linux 64-bit (requires additional actions)
  • Microsoft Azure SQL Database
  • All supported SQL Server editions in Amazon RDS and Microsoft Azure cloud platforms
  • MySQL 5.7 Community 32-bit/64-bit
  • MySQL Standard Edition 8.0 (release 8.0.20 and later) 32-bit/64-bit
  • MySQL Enterprise Edition 8.0 (release 8.0.20 and later) 32-bit/64-bit
  • MariaDB 10.1 (build 10.1.30 and later) 32-bit/64-bit
  • MariaDB 10.3 (build 10.3.22 and later) 32-bit/64-bit
  • MariaDB 10.4 (build 10.4.26 and later) 32-bit/64-bit
  • MariaDB 10.5 (build 10.5.17 and later) 32-bit/64-bit
  • MariaDB Galera Cluster 10.3 32-bit/64-bit with InnoDB storage engine
  • PostgreSQL 13.x 64-bit
  • PostgreSQL 14.x 64-bit
  • Postgres Pro 13.x (all editions)
  • Postgres Pro 14.x (all editions)

Refer to the following topic for details and limitations: Selecting a DBMS.

It is recommended to use MariaDB 10.3.22; if you use an earlier version, the Perform Windows update task might take more than one day to work.

SIEM and other information management systems:

  • HP (Micro Focus) ArcSight ESM 7.0
  • IBM QRadar 7.3
  • Splunk 7.1

Did you find this article helpful?
What can we do better?
Thank you for your feedback! You're helping us improve.
Thank you for your feedback! You're helping us improve.