A website is completely or partially blocked by a Kaspersky application. What should I do?
Latest update: January 27, 2023
ID: 15335
This article concerns:
- Kaspersky Security Cloud
- Kaspersky Internet Security
- Kaspersky Anti-Virus
- Kaspersky Total Security
- Kaspersky Small Office Security
Issue
When trying to open a website, you may get the notification “Prevented visiting a website...” or “Visiting an untrustworthy website has been prevented”
Cause
Kaspersky applications may block access to a website: it may be displayed incorrectly or fail to open completely. This may occur due to the following reasons:
- The site may contain phishing links, malicious code or other threats.
- When the website is accessed, content from the higher-level website may be loaded, which may be considered unsafe by Kaspersky Security Network.
- The site may contain content considered sensitive. If Parental Control is enabled, such site will be blocked.
- Other causes unrelated to threats.
- Issue with a website certificate. This may be a sign of a fake website, also the issue can be caused by an expired website certificate, or a website certificate based on a Windows root certificate that has expired.
For example, on September 30, 2021 a DST Root CA X3 certificate has expired. To view the Windows root certificate on which the website is based, in the Kaspersky notification click View certificate and open the Certification path tab.
If you are the owner of the website which is blocked, see this article for instructions.
Solution
If the notification says that the website is infected, we do not recommend following the instructions below and opening such website.
- If the issue is related to the expired root certificate, update it. For instructions, see this article.
- If you are using Google Chrome and the error text says CERT_DATE_INVALID, check the system date on your computer and the browser certificate expiration date. If the date is correct and browser certificate is not expired, contact Kaspersky customer service by choosing the topic for your request.
- If you get the error Can't reach this page or Connection has timed out, try disabling the Anti-Banner or Privacy Protection component and try opening the page again. Report the issue to Kaspersky customer service by choosing the topic for your request.
- Make sure the Kaspersky Protection extension is enabled in your browser. See this article for instructions.
- If you have Kaspersky Secure Connection installed, try disabling it.
- Disable running of scripts for interacting with web pages: Go to Settings → Network settings. Clear the Inject script into web traffic to interact with web pages checkbox and click Continue. In the lower-right corner, click Save → Yes.
- If the blocked website is secure (HTTPS), try adding it to exclusions from Encrypted connections scanning. See this article for instructions.
- If the issue occurs on a banking or payment page, try disabling Protected browser for this page. See this article for instructions.
- If you get a blocked download or malicious object warning on the website that you trust, take a screenshot of the error and submit it to Kaspersky customer service by choosing the topic for your request.
What to do if the issue persists
- Check the link to the website using Opentip. If the link was identified as safe, add it to Trusted list. See the guide below.
- Try looking up the problem in Community.
- If the issue persists, submit a request to Kaspersky customer service by choosing the topic and filling out the form.
How to add a link to Trusted
- In the main window of your Kaspersky application, click
.
- To learn how to open the main application window, see this article.
- Go to the Protection section and click Web Anti-Virus.
- Click Advanced Settings.
- Click trusted URLs.
- Click Add.
- Add a mask of website and click OK.
- Click OK in the lower-right corner.
- Click Save in the lower-right corner of the window and confirm your action.
The application will not scan traffic from the websites added to Trusted.